Messages in this topic - RSS

Home ? Competitions, Events & News ? New release update: Static lighting and OBJ import

pages: 1 2 3 | Please log in or register, then complete your details to create a post.
15/12/2016 19:20:19

PatMarrNCMuvizu mogul
PatMarrNC
Posts: 1742
primaveranz wrote:
PatMarrNC wrote:

Weirdly for the cube with the window in it, even though the window is not visible if you lift the block above the ground the shadow shows that thre is a hole in the cube. However the window is only in the top and the shadow suggests it goes right through the cube. This is the same behaviour I have seen with .ASE files.


seeing the same thing here.

I'm getting mixed results

size-wise, Some cubes that are larger than other cubes that will import are still failing with the error that the object is too small.

Sometimes when the OBJ imports I can select it and move it around, while other times I can't... and I don't know what determines the difference


OK.. based on your input I was able to get a cube with texture to load ... but i still got an invalid file format error, and the texture didn't show up on the model until I edited the property diffuse texture (which was empty, even though the MTL file clearly showed it)

After getting the cube into Muvizu I was then able to apply BMP, PNG and JPG textures to the diffuse texture box
edited by PatMarrNC on 15/12/2016
permalink
15/12/2016 19:22:44

primaveranz
primaveranz
Posts: 524
I exported the .OBJ from Milkshape3d and opened it in Blender where it appears to have only a single material (I am not a Blender user and find the GUI archane). I created the other material and used the transparent texture but I have no idea how to apply it to the "Window" in my box. So it looks like maybe Milkshape is the culprit in my case.
Would be good to know what tools Muvizu staff would use to create a mesh with two materials one of which is transparent.
permalink
15/12/2016 19:24:02

primaveranz
primaveranz
Posts: 524
PatMarrNC wrote:


OK.. based on your input I was able to get a cube with JPG texture to load (PNGs don't though)... but i still got an invalid file format error, and the texture didn't show up on the model until I edited the property diffuse texture (which was empty, even though the MTL file clearly showed it)


Yep I get that as well.
permalink
15/12/2016 19:35:27

primaveranz
primaveranz
Posts: 524
Pat I have just spent 5 fruitless minutes trying to find the thread where you and Ikes explained how to edit a file to allow transparencies in a .ASE file? Can you find it? I just wondered if there was anything there that might help with the .OBJ file.

Ta.
permalink
15/12/2016 19:39:07

Tangledbliss
Tangledbliss
Posts: 66
You know what guys? - I dont think i am going to bother with .obj models and muvizu - I just havnt got that much spare time
permalink
15/12/2016 20:12:28

PatMarrNCMuvizu mogul
PatMarrNC
Posts: 1742
hmmm.. that time I texture mapped the object before applying the texture and Muvizu imported it without an error

permalink
15/12/2016 20:14:02

PatMarrNCMuvizu mogul
PatMarrNC
Posts: 1742
Tangledbliss wrote:
You know what guys? - I dont think i am going to bother with .obj models and muvizu - I just havnt got that much spare time


It's only time consuming until you figure it out. We're saving everybody else the trouble ;-)
permalink
15/12/2016 20:18:08

PatMarrNCMuvizu mogul
PatMarrNC
Posts: 1742
primaveranz wrote:
Pat I have just spent 5 fruitless minutes trying to find the thread where you and Ikes explained how to edit a file to allow transparencies in a .ASE file? Can you find it? I just wondered if there was anything there that might help with the .OBJ file.

Ta.


I tried what works in FBX files, but it doesn't work in this case.
The solution was to add another parameter in the .mtl file:

d 0.50 (added at the end of the glass material definition)
permalink
15/12/2016 23:03:38

Speedking5
Speedking5
Posts: 51
I tested out the obj import with Windows 3d builder and everything works for the most part. Also turned on the static lighting I still dont really understand what that means but some stuff did look better but darker. a few items did not have the option to click on them most of them worked I thinked they were ones with over high poly count. Most Items I imported in to muvizu were having mini seizure problems nothing bad Not sure if you can do stop the collision like in Blender. 2 things kind of interesting the rocket has a kind of metal texture to it And I just coloured it. Also I was surprised how easy it was to color a 3d oobject in windows builder im definitely going to use it again just for that Srs took like two minutes to paint. Stuff that has multipule objects need to be merged before exporting. I did test out an Obj from another program and it waas jumping all over the place

permalink
16/12/2016 00:00:05

primaveranz
primaveranz
Posts: 524
PatMarrNC wrote:
hmmm.. that time I texture mapped the object before applying the texture ...


I don't understand what you mean there, Pat? Do you mean you opened the UV window in Milkshape and adjusted something on the UV front, whereas before you had just applied the material and left it with the default UV map? Because I have done both but still can't get 2 materials to show in Muvizu. I'll try just a single material and make it transparent.
permalink
16/12/2016 00:02:49

primaveranz
primaveranz
Posts: 524
Speedking5 wrote:
I tested out the obj import with Windows 3d builder


Good work!! I tried downloading Windows 3D builder but it is trying to force me to set up a Microsoft account on my PC, so that ain't going to happen
permalink
pages: 1 2 3 | Please log in or register, then complete your details to create a post.

Home ? Competitions, Events & News ? New release update: Static lighting and OBJ import