Messages in this topic - RSS

Home ? How Do I ...? ? Minimizing collision on Blender FBX exports

pages: 1 2 | Please log in or register, then complete your details to create a post.
06/06/2016 18:31:44

Jwalshiv
Jwalshiv
Posts: 21
Hey folks – apologize for those of you seeing this on both the chat area and this forum, but I'm at the end of my rope. I've spent weeks trying to use some models I purchased. I managed to learn Blender well enough to edit the models a bit and get them into Muvizu, but they are enclosed spaces and the collision mesh is making it impossible to put anything in them, other than characters. Can someone share the process for creating a tiny collision mesh in Blender that allows stuff to pass through most of the model in Muvizu?
permalink
06/06/2016 18:47:46

MrDrWho13Muvizu mogulExperimental user
MrDrWho13
Posts: 2220
The people you'll want to speak to are Ziggy72, Fazz68, urbanlamb, Clayster, or ukBerty.
Some of them will probably turn up later this evening to help out.
Unfortunately, as far as I understand, it's not as easy to remove collision from an fbx files as it is an ase file.
There's some details here: http://muvizu.com/Wiki/wiki/86
Are they relatively complex models? Muvizu has a limit for the number of polygons before things go very wrong.
permalink
06/06/2016 18:53:37

Jwalshiv
Jwalshiv
Posts: 21
Thanks so much – yes, the models are fairly complex, but under the limit and I've been importing them without incident. In looking at all the layers in Blender, I don't see anything called "collision_node" so I'm guessing there isn't actually any collision in the model and Muvizu is creating it automatically.

The solution may be to go back to .ase files, as this seems to have been addressed with them. But .ase's gave me all sorts of problems on import, so I'm hoping not.

Thanks again and I'll keep a look out for a reply from Ziggy, et al.
permalink
06/06/2016 18:55:35

MrDrWho13Muvizu mogulExperimental user
MrDrWho13
Posts: 2220
What sort of problems did you have when importing? ASE is quite a dodgy format, but it tends to work quite well in Muvizu.
Are you able to make a layer called collision_node? If Muvizu's automatically making collision, then making your own should stop it.
permalink
06/06/2016 19:31:13

Jwalshiv
Jwalshiv
Posts: 21
Honestly, I've gone through so many phases of finding an import pipeline that sort of works that I can't remember the specific issues I had with .ase's. But once I got working with Blender and saw .ase wasn't a default export option, I went to .fbx.

I see now that I could go and get a special script to export as .ase, then figure out the ziggy mesh exporter, etc. But it feels like I'm close to the finish line and starting with a new file format seems bound to raise new questions. Plus if the issue is solved by just adding a tiny cube and calling it "collision_node" then that seems like the thing to do. (But I don't understand the details of the process – where to put the cube, etc. Also, I'm not sure if Muvizu recognizes the term "collision_node" and knows what it means, as I got that from a Unity or Unreal Game Engine tutorial.)










Anyway, thanks again for bearing with me and the advice is greatly appreciated!

John
permalink
06/06/2016 19:54:22

MrDrWho13Muvizu mogulExperimental user
MrDrWho13
Posts: 2220
Muvizu uses Unreal 3 so the tutorials for that should apply.
permalink
06/06/2016 20:06:43

Jwalshiv
Jwalshiv
Posts: 21
Indeed - that is my hope, but I just need to follow the proper procedure to export a file to find out. Thanks again for the chat!

John
permalink
06/06/2016 20:44:53

MrDrWho13Muvizu mogulExperimental user
MrDrWho13
Posts: 2220
You might be better off trying out just putting the collision cube on the centre point of the axis and doing a bit of trial and error before the others are online to help out.
permalink
06/06/2016 20:56:13

ikesMuvizu mogul
ikes
Posts: 284
You can bypass the collision if you set the movement of the object you want to place inside to keyframe and put a keyframe at frame 0 and position your object inside. Note that scaling and keep upright do not work after you keyframe it. If you want to place a lot of object inside your model, it's maybe not the best solution.
permalink
06/06/2016 21:18:31

ziggy72Muvizu mogulExperimental user
ziggy72
Posts: 1988
Hey Jwalshiv. Collision is a pain, yes, but it's built in to the way the Unreal engine works, so you gotta learn to live with it and work around it. ASE is the simplest way of making models with 'low' collision, but only really in Sketchup (which doesn't support FBX, and the ASE exporter for Blender does it's level best to drive you nuts at every turn).

For blender, you import your model - let's say it's called MODEL (yes, use caps, seems to avoid problems).
Press N, and go to the Textured Solid tick box and make sure it's ticked (you should see the textures on your model at this point).
Create a little cube (this will be your collision volume). It must be called UCX_MODEL (must!! underscores mean something to the Unreal engine, so only use them like this) You can avoid problems later on by making sure it's at the 0,0,0 axis point (dead centre) of the workspace.
Select MODEL, and Shift select UCX_MODEL
Export as FBX

And that's it. You can help avoid the Muvizu 'jiggle' by setting the centre point on MODEL to the 'centre of mass', and then moving MODEL to the mid point of the UCX_MODEL so everything is as centred as possible. In the FBX export settings, set the Smoothing to Face rather than Normals to avoid the FBX segmented look, and it should look like your source model. Hope this helps (it's actually Urbanlamb who knows most about this process, I just cribbed off her )
permalink
06/06/2016 21:41:29

Jwalshiv
Jwalshiv
Posts: 21
You guys are amazing – this is my first experience with the forums and it's been incredibly helpful. I'm away from my system at the moment, but I'll report back with results later this evening. Thanks also for addressing the "Muvizu Jiggle" which I had assumed was just a fact of life

Deeply appreciate all the help,

John
permalink
07/06/2016 06:33:15

Jwalshiv
Jwalshiv
Posts: 21
Hi all,

Thanks again for all the help. Sadly, my result has been no different. I added the cube, labeled it as instructed and exported, but once imported into Muvizu, nothing can pass through the model or even be created inside of it (shapes just bounce around and fly out). The only step I wasn't able to take was Clicking the Textured Solid tick box, as that isn't an option in my version of Blender. But that doesn't seem like it would effect my collision mesh. I also read somewhere that the mesh needed an empty material, so I tried that, but to no avail. Any further thoughts greatly appreciated!

If anyone is inclined to take a look at the model, here's a link to the Blender file (with no textures, etc, as I don't think those are needed): https://we.tl/LQy0OsSxNY

Thanks once more for any advice you have.

John
permalink
07/06/2016 08:04:00

Jwalshiv
Jwalshiv
Posts: 21
Scratch that! I realized I needed to combine all layers and name the collision mesh after the single remaining layer. (I started by naming it after the file. Doi.) In any event - I now have exactly what I need. Thank you thank you thank you again!

J
permalink
07/06/2016 08:04:56

MrDrWho13Muvizu mogulExperimental user
MrDrWho13
Posts: 2220
Thanks for the update. Good luck with your video!
permalink
07/06/2016 13:11:40

ziggy72Muvizu mogulExperimental user
ziggy72
Posts: 1988
I usually only have a single layered model to take into blender, I didn't take the 'multiples' into account. So yeah, do what you did jwalshiv Good to know you've got it working.
permalink
07/06/2016 15:17:39

urbanlamb
urbanlamb
(Account inactive)
Posts: 1796
Jwalshiv wrote:
Scratch that! I realized I needed to combine all layers and name the collision mesh after the single remaining layer. (I started by naming it after the file. Doi.) In any event - I now have exactly what I need. Thank you thank you thank you again!

J


Models imported need to be one single mesh its just "the rules" of how it works so select all and then click "join" and then after that add your collision box as above. Sorry I dont read these forums often these days.

(Ziggy72 is the newest "blender convert" who has figured it out and once its figured out you wont have issues so he probably has all the right answers now lol. Once people figure this out the chains come off and all of a sudden they realize they can literally make anything. However for some reason people resist said chain removal at times. People hate changing their habits so I blame human nature for this! ^^)

If you decide you want to make stairs or something (which need collision) just build in blocks into the steps and name them UCX_MODEL_01, UCX_MODEL_02 etc etc to add multiple collision points.

I saw a post about something being unselectable on this forum recently. This happens if there is not proper materials assigned and if the mesh has not been joined into a single mesh with materials assigned to each part if there is a single piece of the model that has not got a proper material set up the entire prop wont be selectable.
`````````````````````````````````````
for easy alignment use the "snap to cursor" ability

press "shift c" to snap the 3d cursor to the center
then select the model and join all the bits and then check its all there and then you set the origin to center of mass this is usually the safest
then once that is done snap the object to the 3d cursor
then create your cube and since the cursor is at the center that is where the cube will be so then its all aligned (although I usually snap everything to the cursor one last time before exporting it just to make sure I haven't accidently jiggled anything around)

then apply rotation and location which is all 0,0,0 and it should work perfectly and jiggle no more

I put all this info into a video which is in the wiki along with a few other things all the info is there I think now along with things people dont want to know
edited by urbanlamb on 07/06/2016
permalink
07/06/2016 16:32:14

ukBertyMuvizu mogulExperimental user
ukBerty
Posts: 976
Yes jwalshiv - it's taken me about 5 years to be comfortable with the rules of getting models into Muvizu so you're ahead of the curve. Mind you I did start from literally no knowledge at all at a time when no-one really understood what was going on as Muvizu has had it's own rules...

Urban, you will be glad to know I use FBX 90% of the time now I can reliably get rid of collision. Not migrated to Blender yet though so some things don't change
permalink
07/06/2016 16:49:08

urbanlamb
urbanlamb
(Account inactive)
Posts: 1796
ukBerty wrote:
Yes jwalshiv - it's taken me about 5 years to be comfortable with the rules of getting models into Muvizu so you're ahead of the curve. Mind you I did start from literally no knowledge at all at a time when no-one really understood what was going on as Muvizu has had it's own rules...

Urban, you will be glad to know I use FBX 90% of the time now I can reliably get rid of collision. Not migrated to Blender yet though so some things don't change



....come to the dark side


P.I.M.P.
permalink
07/06/2016 18:13:11

ziggy72Muvizu mogulExperimental user
ziggy72
Posts: 1988
urbanlamb wrote:
People hate changing their habits so I blame human nature for this! ^^)

I always blamed blender's horrible UI... :P
permalink
08/06/2016 20:12:26

Jwalshiv
Jwalshiv
Posts: 21
I've been pretty happy with Blender except I can't figure out how to do anything

Speaking of which – I have an obj I've been trying to export as an FBX, but when I bring it into Muvizu, it seems to be lacking all textures. Anyone know if this is something simple that I'm missing, or have I bought a bad model?

Thanks again!

J
permalink
pages: 1 2 | Please log in or register, then complete your details to create a post.

Home ? How Do I ...? ? Minimizing collision on Blender FBX exports