Messages in this topic - RSS

Home ? Tips & Tricks ? Img sequence & wav file audio sync in Sony Vegas?

the topic is closed
07/03/2016 22:25:06

CloudNinja
CloudNinja
Posts: 92
I've been working with outputting my Muvizu scenes in TGA format & importing them into Sony Vegas @ 25 FPS (the overall project settings is using the "4K 2160-50p (3840x2160, 50.000 fps)" template.
The challenge I'm running into is that when I import the Muvizu wav file into Vegas - it does not always sync the audio from the wav file with the lip sync of the TGA Img sequence?!
I've worked for almost 2 days trying different combinations of FPS or re-rendering - no success.
I've had one, no issue render so far i.e. where the wav file & the img sequence properly synced - I'm wondering that it maybe is all dependent on a no glitch render from Muvizu rather than dependent on what setting I use when importing to Sony Vegas?
Another sanity check question - whatever I see in the Sony Vegas preview window is what I should see in the final output - correct? Seems a bit choppy to me when watching the video in the Sony preview window).
(btw - my I upgraded my video card to NVIDIA GeForce GTX 750 Ti)
Any guidance would be greatly appreciated.
thank you,
.cn
permalink
07/03/2016 22:39:12

MrDrWho13Muvizu mogulExperimental user
MrDrWho13
Posts: 2221
You might be having lag while editing your video at 4k since the 750ti was designed for 1080p. The test I usually use is to upload a private test video to youtube which allows you to check the syncronisation at resolutions your graphics card is more friendly with.
permalink
07/03/2016 23:08:16

CloudNinja
CloudNinja
Posts: 92
MrDrWho13 - thank you for the quick response (as always).
I rendered a short clip and uploaded it to YouTube - still is out of sync.....
FYI - when I export from Sony Vegas to video - I'm using the mp4 / Sony AVC/MVC / Internet 1920x1080-30p template.....
do you know what settings in Vegas should I use given my video card?
Another "test":
I just imported the image sequence and wav file into HiFilm 3.0 Express using the 1080p Full HD @ PAL 25 fps template - same issue.
edited by CloudNinja on 07/03/2016
permalink
08/03/2016 01:10:28

ziggy72Muvizu mogulExperimental user
ziggy72
Posts: 1988
If your source is 25fps, that's what you got to work with. In Vegas, you can get a plugin called Twixtor which changes the frame rate of any clip to a new one, so you can put different sources together at one new frame rate. I use Twixtor to get slowmo out of Muvizu, but you could also use it to resample it up to 50fps or whatever while keeping the same speed (so your audio should stay in sync). Don't know how Hitfilm handles it.
permalink
08/03/2016 01:17:00

CloudNinja
CloudNinja
Posts: 92
ziggy72 - I'll look into the plug in Twixtor right after this post - thanks!
My 2 questions would be -
1 - Muvizu is my source so the FPS is 25 - correct?
2- if I'm importing my tga sequence into Vegas @ 25fps - why would there be a lag in the audio? Is it because of my project settings being @ "4K 2160-50p (3840x2160, 50.000 fps)"? btw - I've previously changed the project setting to 25 fps & it still lags....
with appreciation,
.cn
permalink
08/03/2016 01:25:36

mrmuviz
mrmuviz
Posts: 51
CloudNinja wrote:
I'm using the mp4 / Sony AVC/MVC / Internet 1920x1080-30p template.....


30P might be your problem here if you are doing all 25p.

I live in NTSC land and videos for YouTube that I do start with a 1080 25p timeline in Vegas,
then edit my VO in Vegas and then export it as a 256kbps MP3.
As you see in the picture I put in a buffer so to speak for the audio so on
just so I can get head/eye etc. lined up so when I do
export from Vegas, I export a range that is labeled Full Video.

So now when I bring in the MUVIZU rendered layers for the final edit I start them
at the marker that says "Audio for Muvizu"
The audio "wav" file that MUVIZU produces just gets deleted and not used because
I already have the audio on the VEGAS timeline.

IMPORTANT NOTE - Sometimes VEGAS is a little finiky(spelling? lol)
Right click your MUVIZU layers in VEGAS and go to properties and make sure they are 25p
Sometimes they come in at 29.97

Another Note - You see how I duck down the audio in my VO... I don't care how clean you think your audio is
MUVIZU picks up on everything, doing this gives me less headaches.
I rarely have to do the TALK/SHUSH when I do the ducking.

The 3 dark layers are the muvizu shadow and background layers etc.


Hope that helps.

Hesh
edited by mrmuviz on 08/03/2016
edited by mrmuviz on 08/03/2016
edited by mrmuviz on 08/03/2016
permalink
08/03/2016 02:37:32

CloudNinja
CloudNinja
Posts: 92
mrmuviz - thanks for the tips..I tried:
- exporting my wav audio as 256kbps MP3 & then using that mp3 as the audio file
- making sure my MUVIZU layers in VEGAS and go to properties and make sure they are 25p
My final output still has a lag......
permalink
08/03/2016 02:50:57

mrmuviz
mrmuviz
Posts: 51
can you do a screencast of your settings and or workflow so we can see.

Hesh
permalink
08/03/2016 09:25:31

ritsmer
ritsmer
Posts: 110
I had similar problems getting the quality of the Muvizu generated video perfect for Vegas use while keeping the audio in sync.


1) As a long time Vegas user - I normally use the Lagatith lossless codec for such purposes - and tried it with Muvizu too - and the result is very satisfying IMHO.

The Lagarith codec does not "encode" the Muvizu-generated picture-sequence - it kind of compresses it like i.e. when you compress a .zip file.

You can get the "newest" version 1.3.27 here: http://www.videohelp.com/software/Lagarith-Lossless-Video-Codec
It is easy to install - spoils nothing - and pops up nicely in Muvizu (and Vegas too).
You may then output the Muvizu generated 1080 25p media lossless with no jpg-artifacts etc.
Only back-draw is the 2 GB file-max. allowing about 2 minutes at a time.

2) When editing in Vegas it is a good thing not to force Vegas to transform the media internally to another format(s) (1080 to i.e. 2160 and/or 25 fps to 50 fps to 30 fps etc) as this is bound to introduce different problems.

3) When Vegas has to do these transformations it mostly "resamples" the media (in addition to the transformation) - which gives many problems like "ghost"-frames etc - Vegas even tends to do this resampling when there is no use for it - but it still disturbs the quality - so it is often a good idea to Right click the media on the time line, chose Switches and Disable Resample.

Different Vegas groups have tried for years to persuade Sony to let this "Smart Resampling" not be the default setting - but without result.
permalink
10/03/2016 03:37:55

CloudNinja
CloudNinja
Posts: 92
Hesh & ritsmer - thank you for the tips; I'll be trying those in the near future!
UPDATE: So after taking everyone's input & doing some additional testing here's what I've found/resolved:
1 - it's a muvizu issue, not a Vegas issue.
2 - Muvizu can't do marathon rendering - lol - rendering too many scenes back to back causes the Img sequence & wav file audio sync gap. I've been able to do one, long scene output as TGA (more than 8 secs - 1 min) without any issues. Until now, I had set up my work flow to where I would do all of my rendering back to back...once I spaced it out, the img sequence & wav file audio sync issue disappeared.
thanks again to everyone!
.cn
permalink
the topic is closed

Home ? Tips & Tricks ? Img sequence & wav file audio sync in Sony Vegas?