Messages in this topic - RSS

Home ? For New Users ? sketchup - MuvizuAseExporter extension plugin

Please log in or register, then complete your details to create a post.
20/07/2015 07:59:54

Kreator01
Kreator01
Posts: 14
I have been trying to get this extension into sketchup 2015 without much success keep getting errors as below


Error Loading File HSKP2UNR.rb
Error: C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:1661: invalid Unicode escape
def initialize(sPath = "C:\ut2k4.t3d", bWorld = true, bBl...
^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:2004: invalid Unicode escape
def initialize(sPath = "C:\ut3.t3d", bWorld = true, bBlan...
^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:2520: invalid Unicode escape
def initialize(sAsePath = "C:\ut3.t3d")


^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:3015: invalid Unicode escape
def initialize(sObjPath = "C:\ut3.obj")


^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:4788: invalid Unicode escape
...def initialize(sPskPath = "C:\utx.psk", sPsaPath = "C:\utx.p...
... ^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:4788: invalid Unicode escape
... "C:\utx.psk", sPsaPath = "C:\utx.psa", bBlankFace = true)


... ^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:5854: invalid multibyte char (UTF-8)
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:5846: syntax error, unexpected tIDENTIFIER, expecting ')'
- Dáire \"solosnake\" Stockdale


^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:5896: syntax error, unexpected ',', expecting keyword_end
" , MB_MULTILINE , "HSKP2UNR - H...
^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:5896: dynamic constant assignment
" , MB_MULTILINE , "HSKP2UNR - HardPCM's Export...
^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:5896: syntax error, unexpected ')', expecting :: or '[' or '.'
... Exporter for UT3/UT2K4/UT2K3")


... ^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/HSKP2UNR.rb:6124: syntax error, unexpected keyword_do_block, expecting keyword_end
Sketchup.active_model.active_entities.each do |ent|


^
Error Loading File MuvizuASEExporter.rb
Error: #<SyntaxError: C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MuvizuASEExporter.rb:883: syntax error, unexpected ',', expecting ')'
...ded, do you wish to progress?", MB_YESNO, "Are you sure?")


... ^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MuvizuASEExporter.rb:883: dynamic constant assignment
...u wish to progress?", MB_YESNO, "Are you sure?")


... ^
C:/Users/Kevin/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MuvizuASEExporter.rb:883: syntax error, unexpected ')', expecting :: or '[' or '.'
...s?", MB_YESNO, "Are you sure?")


... ^>



is this exporter incompatible with the sketchup version i am using ... if so what version is it used for sketchup 8??
where can i find that dload?


and on another note the trial does not allow import of own objects, and the object movement does not work correctly bugs? Luckily I have an old version of muvizu on my xp machine and can test out new models But before I intend to spend money on a full version I would like to be re-assured that these problems are not carried forward to to the paid for version.
permalink
20/07/2015 11:26:42

MrDrWho13Muvizu mogulExperimental user
MrDrWho13
Posts: 2221
You'll need sketchup 8 for the plugin to work because they seem to have removed plugins for newer versions. (You can get it here: http://www.filehorse.com/download-sketchup-make/old-versions/ )
I suggest you use the ziggymesh plugin because it saves trouble that muvizu has with collisions: http://rodneyandberty.com/downloads/

As for the 3d warehouse, you'll need to open it in your browser and import the models from there if you want them because they also removed this ability from within the program on sketchup 8.

I believe that object movement is unaffected but there is a bug stopping the animation of object properties. You could use the older version until they fix these bugs if you want to test if your object works. (However I do think that Play+ at this price is a steal)
All the known bugs of this version are here: http://www.muvizu.com/Forum/topic5025-6715-release-bugs.aspx#post25768

I hope this helps,
MDW13
edited by MrDrWho13 on 20/07/2015
permalink
21/07/2015 23:07:49

Kreator01
Kreator01
Posts: 14
Thanks for the info MDW13, is there anywhere i can get an old version of muvizu , so I can test the objects I have made ( Never had any trouble with it the last time I used it, but that was some time ago!) and what is max faces that I can do with the ASE exporter. As a lot of my models are high poly and am unable to test them currently. I need to see how high can go with lo polys
permalink
05/12/2016 06:01:10

animall
animall
Posts: 17
In "SketchUp 2017" plugin folder still exists as you can see below, but in 64bit version of SketchUp 2017 "HSKP2UNR_MUVIZU.rb" as well as "MuvizuASEExporter.rb" creates an error and doesn't work. Native ".fbx" exporter from "SketchUp 2017" works, if the texture is in the same directory when imported into Muvizu, but transparency doesn't work. As majority moves to 64bit area, it would be great to have 64bitversion of these Muvizu plugins as well . (what do you think ziggy? Your previous plugin was great )

============

*.rb files
If you have a file with the .rb extension, you can install the plugin by placing the Ruby script file into the appropriate folder, and then restarting SketchUp.
Windows - the default location is:
    SketchUp 2017: C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins
permalink
Please log in or register, then complete your details to create a post.

Home ? For New Users ? sketchup - MuvizuAseExporter extension plugin