Messages in this topic - RSS

Home ? Importing Assets ? Opacity problem

the topic is closed
29/02/2012 18:29:22

ukBertyMuvizu mogulExperimental user
ukBerty
Posts: 976
My learning curve today relates to opacity.

Once again, I have no idea what I'm doing !!

I can import models from Sketchup into Muvizu and apply .png with transparent or opaque areas. To do this I use the following settings:

  • Don't use ID textures
  • Map alpha to opacity
  • No ambient occlusion map
  • double sided facing

The model imports and I can apply a .png to the faces and transparent areas appear fine. All looks lovely.


I then save the set and open it again and things are not as it was saved. The objects that have been imported using the "opaque" setting are now totally opaque - all faces. Even areas that were set to a solid block of colour are opaque. Resetting the colours does not change the fact that everything is opaque.

Is this a bug or is there a way round this ? Effectively I can't use opacity as I can't save my sets !

Thanks, Berty
permalink
29/02/2012 19:28:33

ziggy72Muvizu mogulExperimental user
ziggy72
Posts: 1988
Berty, the Wise One (otherwise known as Dylly) has already advised me to use Single Sided to make the transparency work, and it worked. I'd go with that.



Oh, also, I've found that the whole object needs to be transparent - mixing opaque and transparent doesn't seem to work no matter what (believe me, I've tried importing stuff using every combination of settings there are, and it just wont do it). That's why I created panes of glass (with very little collision) to put into opaque objects. As long as they're static, it's a workable solution I guess.
edited by ziggy72 on 29/02/2012
permalink
01/03/2012 08:15:46

ukBertyMuvizu mogulExperimental user
ukBerty
Posts: 976
ziggy72 wrote:
I've found that the whole object needs to be transparent - mixing opaque and transparent doesn't seem to work no matter what


Thanks Ziggy - that's what I've found. This is going to be an issue for me, but I may be able to get round it now you have explained effectively how to turn collisions off, but it's a lot of work.

Could someone at Muvizu confirm this please ? As I say it imports OK and you can get it looking just great - it's just that the .set will not open like it was saved - I can send examples in if you like ?

Berty
permalink
the topic is closed

Home ? Importing Assets ? Opacity problem